做个有深度的程序员 — YuanGe
修改PhpSpreadsheet Composer配置所依赖的php所需版本
修改PhpSpreadsheet Composer配置所依赖的php所需版本

修改PhpSpreadsheet Composer配置所依赖的php所需版本

昨天我们实现了利用PhpSpreadsheet来自动生成excel,但前提是在本地服务器。我本地服务器的php版本是7.3.4。

但是当我上传到服务器运行时就报错了

报错是说Composer配置所依赖的php版本>=7.3.0

我们打开报错的文件

可以看到上!(PHP_VERSION_ID >= 70300) ,判断了当前服务器的php版本。我们只要修改这个值就可以了

修改好后上传到服务器,能正常访问。ok。没问题了。打开excel也正常。

理论上就这样就可以了,但我们想想,修改这个值后会不会出现问题?为什么我们修改了配置文件运行却一切正常?

我们打开官方文档。

可以看到上面写这:PHP 7.2 或更新版本使用 PhpSpreadsheet 进行开发

这或许就是为什么我们改成70200不会报错的原因,但有没有上面隐藏的bug就不知道了。

最好了处理方法应该是升级服务器的php版本,不要对platform_check.php进行任何修改。

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

-->